PowerApps, SharePoint library images and mobile devices - Another setting to check to display images from a SharePoint library

Author by Chris Chance

Recently, I was asked to put together a PowerApp/Flow demo as part of a presentation to show a client how their inspectors could use SharePoint to automate the process of collecting and recording inventory information from construction equipment

Challenges

Configuring a PowerApp solution to capture pictures and upload them into a SharePoint Library along with data about the image seemed simple enough to do.

The simple became very interesting.  First, getting pictures into a SharePoint library requires that they be converted to a binary format. Fortunately, a number of others have blogged about this, so it was not dificult to find a number of approaches for this. Paul O'Flaherty's video was especially helpful describing the Flow steps to accomplish this. 
 
Then I ran into (as many others have) the issue that PowerApps does not support displaying images from a SharePoint library on a mobile device although they will display just fine in PowerApps in a browser.  This seems to be due to authentication issues that (hopefully) Microsoft will address.

Workaround . . .  well, almost

After a little more research, I found that I needed to do the following:
  • Create a Picture column (named Photo in my library) in the library holding the images and format it as Hyperlink
  • Insert a Get file properties action step in the Flow between the Create file action and the Update file properties (renamed to Add image data in my Flow) to get the image file properties ( kudos to Zack Shane for this step) for use in subsequent Flow steps
Step1-(2).png
  • Modify the Add image data action step and assign the Dynamic content, Link to item to the Photo column
Step2a.png

This in essence creates a link to the document that can be used by PowerApps to display the image from the library
  • Return to the library and format the Photo column as Picture
  • Modify the PowerApp to include the Photo column on the Detail and other screens where the image will be displayed.
This should have resolved the issue . . .

Finally

It may well have resolved the issue for others, but not for me.  I still could not view images on my phone.  After double checking my steps and making certain that I had indeed changed the Photo column back to Picture. I started digging into the Detail screen on my PowerApp
 
When I edited the field associated with the Photo column, I found that it was set to View text. How and why it was set that way, I don't know.
 
Step3a.png
  • After changing it to View image, the image displayed properly in my phone
Step4a.png

In closing

I hope this helps someone else.  I have certainly made use of others' knowledge and experience